Fandom

Pixelmon Wiki

Using Texture Maps In Techne

659pages on
this wiki
Add New Page
Comments2 Share



Basic Texturing

Alright, I've noticed a lot of folks don't seem to know how to texture. In the past, I've simply linked them to another tutorial on DeviantArt and was done with it, but it's starting to get out of hand and I'm not really in the mood for posting that tutorial over and over, so I'm just going to make my own tutorial that hopefully everyone will read. No pictures, because quite honestly, I don't really feel they're needed as it's actually really simple.

First, take a look at the left side of Techne, and underneath you'll see something that says 'Texture Offset'. Use that to move the bits of texture on the texturemap in the top right to your liking. One important tip is that you can stack texture bits on top of each if they're similiar parts (i.e. stacking all the leg textures together). Use your best judgement when stacking. If you're paranoid or just simply need more space, you can always boost the texture size by going into File > Edit Project and adjusting the height and width there.

Now, after you've got your texture map all sorted out, go to File > Export As > Texturemap. This should pop up with an option asking you what to save the texturemap as. I personally use the .png extension and give it a simple name such as 'SandileTexture,' but whatever works for you. Save the texturemap in some place you'll remember easily and then go to Edit > Load Texture and load your texturemap onto the model. The model should turn all sorts of greens and blue and reds, this is normal.

Open up the texturemap in your pixel editing program of choice, I use Paint.NET, but again, whatever works for you. There, you can begin editing the texture to your liking. If you forget what a particular bit of texture is for, you can click around and select some parts of the model and their texture bits will darken. For bits that are stacked, you'll have to fiddle with the texture offset to see where they belong, but they can always be moved back into place without any other complications, so it's no big deal.

One important tip I can give is to always save the texture with the same file name. If you have Techne open and the texture loaded onto the model, you'll be able to see any changes you've made to the texture on the model automatically, which can be a big time saver It's a lot less hassle than loading a new texture onto the model each time you make a change, and it saves space on your computer.

So, that's it. If you have any questions or if you think I've missed a step somewhere, please let me know and I'll correct it. And for the new modelers out there, once you've gotten the hang of texturing this way, I encourage you to check out my HD texturing tutorial, as we're trying to encourage all of our modelers to start using HD textures for their models to hopefully obtain a cleaner look to them.

HD Texturing

Alright, I'm going to show you, step by step, how to give your models HD textures. I'll try to make the tutorial as clear as possible, but if you have any questions, just drop a quick post and the other modelers and I will be glad to help you out.

First, let's start at the very beginning, which would be setting up the texturemap. Don't set any texture offsets right now, as they will not remain the same anyway. Go to File -> Edit Project, and from there, edit the size of the texture map. I'm not certain, but I'm fairly sure you have to keep it relatively similar to the default size (i.e. 64x32, 128x64, 256x128, or 512x256). You could try to mix and match, I suppose, if your model end up with more tall than wide textures, but just be cautious when doing so. Anyway, for this tutorial, I'll be using a 256x128 texturemap, which'll give me four times more room for texturing than the default 64x32. 128x64 would only give you twice as much (I'm not even too sure how that'd work tbh, anyway whoever wants to give that a try, please do share your findings), and 512x256 would give you a whopping eight times as much room. I won't need that much room for Seel obviously, as it's a very simple model, but for models that could use much more detail in their textures, well, there ya go!

Anyway, here's my settings for the texturemap now;


2Seeltutorial1

If you'll notice, the texture offsets in the top right suddenly look a lot tinnier than they normally do. Go ahead and export your texturemap now. Yes, without the texture offsets. As I said already, they don't matter right now. Got it exported? Alright then, let's move on. Set the texturemap back to 64x32, then take the 256x128 texturemap and fill it in with a random color-doesn't matter what color, though I think it'd be preferred if it was the model's base color, as that'd make texturing it easier, but you can do whatever you want. The reason for filling in the texturemap is so that the model doesn't go invisible when making the texture, which would obviously be incredibly annoying. Go ahead and move your texture offsets into place now as well, since we're not messing around with the texture sizes anymore.


Seeltutorial2


Alright, so we've got our brand new texturemap, all the offsets have been set, time to load up the texture and begin experi-


Seeltutorial3


Oh no, this message. Get used to it folks, you're going to see LOTS of it whilst you're editing the textures, as long as you're using this method anyway. Just hit 'No' every time you see it-if you hit yes, the texture you loaded onto the model will go back to the default size and you'll lose any HD textures you had. The worst part is that, while you're editing the texture, every time it loads onto the model, that message will pop up. Very frustrating, to say the least. I'd recommend saving a backup of your texture every time you edit it, just in case you accidentally hit 'Yes'. Well, with that annoyance cleared up, let's move on to the textures. Load the texturemap into your pixel editing program of choice, and from here, it really is just trial and error, as unfortunately, as you'll no doubt notice, we've had to give up those helpful guidelines that showed us where each texture offset was located on the texturemap, so we'll just have to wing it from here. Though I do have one small tip that may help. When texturing, keep Techne open and never change the name of the texture file unless you really need to, such as creating a back-up. As long as you keep saving over the same file, Techne will update live with any new additions to the texture; you'll of course have to load the texture onto the model at least once, but afterwards, you won't need to do it again. The only downside is, of course, that message. Any time you save changes to the texturemap, that message will end up popping up on Techne, which is why I always recommend creating a backup first, especially if you're like me and like to save the texture after every little change to make sure it looks good on the model. Just keep fiddling with the textures, and you'll eventually be able to figure out where everything is relative to each texturemap. Well, that wraps up this tutorial. If you have any questions or need something cleared up, feel free to leave a post or message me or another modeler who's been able to get this to work, and we'll be glad to help clear up any confusion :3.

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.